lmmp.net
当前位置:首页 >> vB错误:对象变量或with块变量未设置 请大神帮我看看 >>

vB错误:对象变量或with块变量未设置 请大神帮我看看

可能的情况 1 rs1无数据 2 确认数据库是否有 “本级编号” “种类” 这些字段,字别写错了, 3 是否有null数据 把断点设在 这里 Do While rs1.EOF = False 看能不能正常运行到那

出现这个问题时要查看是不是给对象或变量初始化如: dim rs as adodb.recordset 直接用rs=**的话会报上面的错,应该改为set rs=**,要不就定义时用 dim rs as new adodb.recordset rs=**就不会报了。 你这个是应该要 set Adodc1.Recordset=**,...

对象变量或 With 块变量没有设置(错误 91) 创建对象变量有两个步骤。第一,必须先声明对象变量。然后必须用 Set 语句将一个正确的引用赋值给对象变量。同样地,With...End With 块必须先用With 语句进入点来执行初始化。此错误有以下的原因和...

1、你要在工程属性中设置启动对象为Sub Main 2、你要在工程中引用DAO 3、Set rsdata = db.openrecord("生产场所数据表") 要改为:Set rsdata = db.OpenRecordset("生产场所数据表") 4、Do While Not radata.EFO 要改为:Do While Not rsdata.EOF...

请检查data1.recordset是否不存在,是否未打开,是否未执行查询。 —————————————————————————————— 你好,我发现原因了,你的form_active事件里没有对data1.datasource赋值,就直接使用了recordset,这样的话,recordset里是不会有值的,我加入...

在提示错误的代码行位置,采用如下格式,以免返回的记录为0 Adodc2.Refresh If Not Adodc2.Recordset.EOF Then Adodc2.Recordset.MoveFirst ...... End If

对象变量或 With 块变量没有设置(错误 91) 创建对象变量有两个步骤。第一,必须先声明对象变量。然后必须用 Set 语句将一个正确的引用赋值给对象变量。同样地,With...End With 块必须先用 With 语句进入点来执行初始化。此错误有以下的原因和...

这里对象又不是只有一个,不说清楚点 1 检查一下文本框名有没有写错的 2 在建立数据源连接时,有个测试按钮,测试一下能不能连接成功 3 字段索引是不是从1开始啊?如果是Adodclogin.Recordset.Fields(3) = "customer" 出错的话,那应该从0开始。

对象变量或 With 块变量没有设置(错误 91) 创建对象变量有两个步骤。第一,必须先声明对象变量。然后必须用 Set 语句将一个正确的引用赋值给对象变量。同样地,With...End With 块必须先用 With 语句进入点来执行初始化。此错误有以下的原因和...

给对象起名字不能和vb6的关键字、函数等冲突 将 menu 另改名

网站首页 | 网站地图
All rights reserved Powered by www.lmmp.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com